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Several images can be stitched together (sometimes referred
to as "montaging") through the use of Photoshop. Edges of the
images can be feathered and the process automated to reduce the
hours of work that can go into this procedure.

Before going any further, let me be quick to say that more
than one company has developed protocols to accomplish image
stitching. When your lab is looking at large fields, while needing
to resolve fine details, then I would strongly recommend the pur-
chase of a system designed for this purpose. Issues surrounding
motorized stage accuracy, problems with tilting when a camera
is perched on a long optical tube, and image to image correction
for contrast, color and uneven iUiimination can all contribute to
confounding issues when image stitching. These companies have
worked through these problems with off-the-shelf systems.

When lx to 2x resolution is needed for brightfield illumina-
tion, microscope slides can be scanned on some slide scanners
(the Nikon 35mm film scanners, for example) and for fluorescent
illumination, microarray scanners can be used.

For the once-in^a-blue-moonuser,however,Photoshop works
as an alternative. Before attempting image stitching, you may want
to verify that it cannot easily be done in a program designed for
that purpose (such as Panavue, or the image stitching protocol
included with Photoshop Elements). Typically, any image series
will work as long as no large areas of white or black exist, which
is almost sure to happen with scientific images at the outer edges
of the sample. In the end, these programs work well for photos
of mountain ranges, but poorly for scientific images.
Motorized stage and imaging system.

You will need to locate
a decent motorized stage
that has been checked for
x and y alignment against a
microscope grid. In my own
experience, motorized stage
accuracy is commensurate
with the cost, and it seems
that costs need to be closer
to $20,000 than to $10,000
for the accuracy needed for
repeatable results. Calibra-
tion grids imprinted upon
microscope slides can be
obtained from your mi-
croscope salesman or from
Microb right field, Inc. Thex
and/borders of these grids
must move in parallel to
the edge of your image area
versus moving at an angle.
Check that by finding the x
and/ border of the grid, and
then moving the x ory mo-
tors with the joystick while
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for large reconstructions. If you use
a "zig-zag" method for movement of
the motorized stage, then every other
row will be named in reverse order.
Either rename each image, or make a
second action later to stitch togetlier
the reversed rows.

observing parallelism. Sometimes a camera that is perched on a
phototube is not parallel to the stage. A bubble level can be placed
on a camera, assuming the back of the camera and the chip are
parallel and this can be compared to what the bubble level reveals
when placed on the stage. In this way, the direction of tilt can be
determined and you can figure out how to correct the tilt (perhaps
another good use for duct tape!).

I have had the best success with motorized stages when col-
lecting across in the x direction, having the stage move down to
the next row, and then having the stage move across in the opposite
direction, and so on. This creates some difficulties with file nam-
ing (the first row counts up, the second row counts down, and so
on), but that can be solved by renaming later on, or by providing
two actions (more on that later).
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Fig2. (Top) For high resolution cameras, you may want to cut image

sizes m half. Check first, however, to determine whether important
information is lost and then decide upon the percentage of file size reduction,
Unless the image is being reproduced on a poster, the futat image need-be
no larger than the size of a cover (typically, 8.5X11 inches at 300 or 400
pixels per inch: 3400X4400 pixels at 400 ppi), (Middle) Note that the size
reduction is done according to pixels as the unit of measurement, making
the "Document Size" entries unimportant. Be sure Constrain Proportions
and Resample Image arc checked. Make an action while doing this so
that this action can be applied to all your images automatically. As a part
of your action, you should not include opening the image (File > Open).
(Bottom) Use File > Automate >.Batch to accomplish automation. If you
wish to apply the automation to all the file folders, then check Include All
Subfolders. Otherwise, you can work folder by folder and save image files
to new folders if you wish to preserve original images at high resolution. In
that instance, click on the arrow next to Destination to reveal drop down
list and make the destination Folder.
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Pig% (Top) Make a template into which a row of images can be
placed; or, if you are working with a handful of image files, then make the
template somewhat larger than the sum of the x and y dimensions of all
images together. In tins instance, the template is the sum of 5 image files
(S at 650 pixels for a sum-or product-of 3250 pixels). Again, note that
the Resolution does not need la be changed when working with pixels as
the unit of measurement. You can record this as an action to be used for
subsequent rows. Give yourself additional room in case the images fi>rm-a
"stairstep." (Middle) Make an action that includes Select All, Cut, Close
[mage, Paste (image of tills action not shown). Then apply ihis ucdon using
File > Automate > Batch to the first row. (Bottom) Ail images should be
stacked upon one another as layers. Remember that you should do all the
above by starting with a screen cleared of alt image files, and do not zoom
in on the template before automating the stacking of images (otherwise, the
images will not be exactly centered, making the next steps more difficult to
accomplish).

Uneven illumination across the field is almost always a given.
If your imaging system provides shading correction (also called
flatfield or blank field correction), then use this protocol when
obtaining images. Otherwise, uneven illumination will have to
be corrected later in Photoshop (not covered in this article).
Especially with low magnification (using 2x, 4x or lOx objec-
tives), issues with uneven illumination become near-impossible
to overcome. You may want to overlap images to a larger degree

{e.g., one-third image overlap) since most illumination problems
occur at the left or right hand sides of the field.

Be sure to provide plenty of overlap from one row to another,
especially critical when a less accurate motorized stage is used,
or when uneven illumination is dramatic. The amount of time it
takes to set up this method and to collect images results in greater
frustration when the bottom images do not meet up with the tops.
This may go without saying, but images should be named with
3- or 4-digit numbering extensions (e.g.,"red001 ,""redO02" etc.)
to avoid problems with the order later on.

Finally, cameras MUST be set to a manual exposure. If this
isn't done, then each image will be exposed slightly differently
leading to brighter and dimmer images so that all do not match
in terms of brightness. Find the ideal exposure on the brightest
area of interest and let all other areas be exposed similarly. The
brightest area may take a while to locate, but it is well worth the
effort.
Steps in Photoshop: Reduce File Sizes

Once images are collected, the first matter to be resolved
has to do with file sizes. With the advent of megapixel CCD's,
file sizes can.easily be over 4 megabytes for each color image (for
TIFF files; avoid JPEG images, since these result in a loss of im-
age information). All but the most robust computers can handle
a great number of these files handily. Often, a decision about
how far lo reduce file sizes must be made. This can be done by
experimenting with a single representative image to check the loss
of important detail against varying cuts in the file sizes (what I
mean here is the reduction of PIXELS across and down). I start
by reducing the file to one-half the number of pixels across and
down using Image Size under image on the menu (be sure Resa-
mple is checked when doing so). Then i make a decision about
whether to increase or reduce the file size further based upon
whether important details remain.

If more than one camera exists in your lab, use the camera
with the LEAST pixels across and down. That may seem coun-
terproductive—after all, this process is being done to increase
resolution—but the limiting factor, ultimately, will be the number
of pixels across and down in the final, image-stitched photo: even
full-size reproductions in scientific journals will only require 4400
pixels across in the long dimension. Not many of these images
are destined for posters.

The idea of reducing file sizes makes all of us uneasy. For
some reason it's more comforting to make the montage of im-
ages at full resolution, and then make that image smaller in file
size than it is to throw away resolution at the get go. After one
experience with even smaller montages of 12 or so images, users
often change heart because a computer can take so long to plug
away; or, worse, it crashes.
Place linages into Folders by Rows or Columns

Again, because of file size issues and the computer require-
ments for crunching through large numbers of images, it is best
to place into folders either rows or columns, especially for larger
numbers of images. Label the folders"lstRow001,""lstRow002"
and so on. In Photoshop, the images will be stitched together
into continuous rows or columns first, and then the completed
rows or columns will be stitched from top to bottom or side to
side in a second series of steps.
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Steps in Photoshop,
Under File > New make a template upon which to paste your

images. The template needs to be as long horizontally (assuming
rows) as the number of images collected. Simply multiply out
the pixels across in a single image by the number of photos in
that row. Thus, if a single image is 1000 pixels across and you've
downsampled it to 500 pixels, and you have 20 images across,
you'd set the new image width to 10,000 pixels. Set the height
to give enough room for skip in the stage. Thus, if the height of
each image is 800 pixels, set the height to 1200 or so, just in case
the stage had moved uphill or downhill, causing "staircasing'bf
the images. Excess space can be cropped off later.

The template will open so that it is visible from one end to the
other. Do not zoom in! The next step requires that all images be
pasted in the centermost position on the template, and that only
happens when the entire image is visible on the screen.
Make an Action.

Fig4. While you arc carefully aligning images next to each other, and
while zooming in and out to be Hire you have matched up features, he sure
to record what you've done as an action, Start with layer 1, then 2 and
so on. This action ant then be applied to siibsgqiiiflt ft)ws using Batch.
Optional: You can determine x and.y locations of your images by keeping
the Info box open, In that rhnnhev you can figure the numeric positions of
images as you move them into place. In Photoshop 5x, these values can be
typed in using the Numeric function (Edit>Transform > Numeric). Infix,
7x and Bx, the values can be typed in appropriate places at the bar under
the menu. Use only the Transform function and then the boxes under the
menu will appear. Note that some stages move at a different distance for
the- second image than for subsequent images along rows.

action "Stitch Into Row." You will need to start by making an
adjustment layer so that contrast and brightness can be adjusted
in order to see details. Because the first row is mostly black (for

Open the Actions dialogue box (under Window > Show Ac- darkfield images) or mostly white (for brightfield), given that the

tions). Click on the upper right arrowhead and select New Set
from the drop down list (for Photoshop 5x and above). Name this
set "Image Stitching," Again reveal the drop down list and select
New Action. Name it. This action will be used for subsequent
rows in order to save time.
Copy first image onto the template while recording the ac-
tion.

Click on the record button (the round, red button) to turn
it off for the moment. Open the first image from the first row,
then click the record button (this is done so that the action does
not think it only needs to open that particular image file). Under
Select choose All, under Edit choose Cut, under Image choose
Close (don't save), under Edit choose Paste (to paste the cut im-
age onto the template). Stop recording the action by clicking
the Stop button (the black square icon) at the bottom left of the
actions dialogue box.
Automate pasting onto the template.

You have now successfully created an action that you need to
apply to every image in the folder you have named
"Row 1." Now automate the process of opening
eadi image in Row 1 so that all can be pasted onto
the template. First you will need to eliminate the
image you have already pasted onto the template so
that the template can be clear of images. Click on
the template, choose the Layers dialogue box (under
Window > Show Layers), then drag the layer into
the trash icon at the bottom of the Layers dialogue
box, or click on the arrowhead at the top, right and
choose Delete Layer from the drop down list.

Under File, choose Automate > Batch. Tn
this dialogue box, you will need to choose the
Source for the first row (the folder named "Row
1"). Click Okay, and all the images in that folder
will be placed on the template, one above the other
(see Figure 3).
Create a Second Action, move images into place
layer by layer.

Again reveal the drop down list in the Actions
dialogue box and choose New Action. I name this

first row records image areas above or below the area of interest,
it will need to be modified so that every little speck can be seen to
help with alignment of images. Under Layers on the menu, choose
New Adjustment Layer,then Levels {or Brightness/Contrast). Zoom
in to the image (control/command key & + key) and adjust con-
trast and brightness until every Last speck is visible. This layer will
be thrown away at the end, so don't hesitate to be bold.

Now you are ready to move images into place. Click on Layer
1, and move that layer to the extreme left or right (depending on
the movement of the stage and the placement of your microscope
slide when acquiring images). Next click on Layer 2 and move that
image so that fiduciary marks (specks) line up. Spend as much
time as you need in order to line these up, zoom in and out, if
necessary The placement will not be recorded in the action until
you choose Layer 3. Do the same for Layer 3, and for each layer
until finished. When done, remove the Adjustment Layer (the top
layer) by clicking on the top, right arrowhead to reveal the drop
down list and click Delete (or drag in the trash icon at the bottom

Fig5. After making rows, make another template to accoinodate the number of rows and
the width. You can \ecord another action while moving rows into place. Inset shows what
occurs when shading correction is not tised with the camera (if available), or when images do
not have enough-overlap.
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of the Layers dialogue box). Be sure to click on the stop icon at
the bottom of the Actions dialogue box after you do that.
Numeric Values.

You can move images by typing in x and y positions. This
function is called "Numeric" in Photoshop 5x, and in 6x and 7x
it is available on the submenu. It is available when you choose
Transform (Under Edit, choose Transform; also choose Numeric
in 5x). After manually moving Layer 2 and Layer 3 into place,
stop recording the action by clicking the slop button at the bot-
tom of the Actions dialogue box. Click on the triangle at the left
of the Move Current Layer step in the Actions dialogue box and
look at the x and y values. You can see the amount you moved
between the 2nd and 3rd layer, and by subtraction you can figure
the difference. You can then determine where to place Layer 4,
as long as your stage is very accurate. Click the Record button
in the Actions dialogue box and continue. Under Edit, choose
Transform (andthenNufriericin5x). Place the number you have
determined into the x and/or y boxes (be sure Relative is checked
in Photoshop 5x). The layer will move automatically into place.
Note that some stages move in a shorter distance when moving to
the 2nd image in a row than subsequent images, so you may want
to move a 4th layer manually into place in order to be certain of
the x, y travel in pixels.
Save Completed Row.

Be sure to save the row you've created into a separate folder.
I call this folder "All Rows." If you are satisfied with the way the
row looks, then flatten all the layers and save the image as a TIFF
file (under Layer on the menu, select Flatten Layers). If you need
to correct for subtle changes in brightness and contrast, or for
uneven illumination issues, men leave the row in layers and save
as a Photoshop image. It is best to adjust for these changes when
the entire montage is assembled because a target exposure used
for matching all other individual images is easier to identify when
all images are on the same page.
Combine Rows together to make final image.

Repeat above steps for each row (make template manually,
run Batch Automation using "Select All, Cut, Close, Paste" click
on the arrow key at the bottom of the Actions dialogue box after
clicking and highlighting "Stitch Into Rows"). Now make a final
template into which rows can be cut and pasted after determin-
ing the final dimensions. Again, under File > Automate > Batch,
run the ''Select All, Cut, Close, Paste" command, only this time do
so on the file folder named "All Rows." Again all the rows will be
pasted on top of each other in the final template. Create a new
action called "Combine Rows" and then move each layer into place
starting with Layer 1. Be sure to stop the action when done.

If all goes well, images will match up with some overlap. The
final image is completed, which can be saved at the large file size
for full resolution as a photoshop file, and then saved as a second
image as a TIFF file at a target resolution of 400 dots per inch at
no more than 8.5 or so inches across (assuming a publication size
of a full page on standard letter pages).

Assuming good protocol from the start (good alignment of
camera, stage and microscope slide, shading correction, manual
settings on the camera to avoid uneven brightness) images should
be seamless or nearly seamless, •
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